SectorOffsetProperties Class
Sector properties during offset.
- this.normal may be initially assigned as the facet normal but can mutate by averaging with neighbors.
- this.xyz is initially the base mesh xyz but is expected to move along the normal.
- this.count is used locally in computations.
Methods
Name | Description | |
---|---|---|
constructor(normal: Vector3d, xyz: Point3d): SectorOffsetProperties | ||
setOffsetPointAtDistanceAtHalfEdge(halfEdge: , distance: number): void | ||
setXYAndZ(xyz: Readonly<WritableXYAndZ>): void | ||
accumulateScaledNormalAtHalfEdge(halfEdge: , scale: number, accumulatingVector: Vector3d): void Static | ||
almostEqualNormals(sectorA: SectorOffsetProperties, sectorB: SectorOffsetProperties, radiansTolerance: numberGeometry.smallAngleRadians): boolean Static | ||
edgeHasLargeExteriorAngleBetweenNormals(edgeNodeA: , edgeVector: Vector3d, averageNormal: Vector3d, offsetDistance: number, radiansTolerance: number...): boolean Static | Compute the angle between plane normals on opposite sides of the edge. | |
getSectorPointAtHalfEdge(halfEdge: , xyz: Point3d, xyzArray: GrowableXYZArray): boolean Static | ||
pushXYZ(xyzArray: GrowableXYZArray, halfEdge: ): SectorOffsetProperties Static | ||
radiansBetweenNormals(sectorA: SectorOffsetProperties, sectorB: SectorOffsetProperties): number Static | ||
setNormalAtHalfEdge(halfEdge: , uvw: Vector3d, distance?: number): void Static | ||
setXYZAtHalfEdge(halfEdge: , xyz: Vector3d): void Static | ||
sweepRadiansAroundNormal(nodeA: , upVector: Vector3d): undefined | number Static |
Properties
Name | Type | Description | |
---|---|---|---|
count | number | ||
normal | Vector3d | ||
xyz | Point3d |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.