clipPolyfaceInsideOutside MethodStatic
Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet
- accumulate inside and outside facets -- to destination.builderA and destination.builderB
- if
destination.buildClosureFaces
is set, and also build closure facets - This method parses the variant input types and calls a more specific method.
- WARNING: The new mesh is "points only".
- outputSelect applies only for UnionOfConvexClipPlaneSets -- see clipPolyfaceUnionOfConvexClipPlaneSetsToBuilders
clipPolyfaceInsideOutside(polyface: Polyface, clipper: ClipPlane | ConvexClipPlaneSet | UnionOfConvexClipPlaneSets, destination: ClippedPolyfaceBuilders, outputSelect: number0): void
Parameter | Type | Description |
---|---|---|
polyface | Polyface | |
clipper | ClipPlane | ConvexClipPlaneSet | UnionOfConvexClipPlaneSets | |
destination | ClippedPolyfaceBuilders | |
outputSelect | number |
Returns - void
Defined in
- polyface/PolyfaceClip.ts Line 458
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.