findOrAddNormalInLineString Method
Add a normal to the polyface.
findOrAddNormalInLineString(ls: LineString3d, index: number, transform?: Transform, priorIndexA?: number, priorIndexB?: number): undefined | number
@returns the normal index in the polyface.
Parameter | Type | Description |
---|---|---|
ls | LineString3d | the linestring. |
index | number | Index of the normal in the linestring's surface normal array. |
transform | Transform | (optional) transform to be applied. |
priorIndexA | number | (optional) an index of a prior normal to check for possible duplicate value. |
priorIndexB | number | (optional) another index of a prior normal to check for possible duplicate value. |
Returns - undefined | number
the normal index in the polyface.
Defined in
- polyface/PolyfaceBuilder.ts Line 488
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.