addFacetFromGrowableArrays Method
Add a polygon to the evolving facets.
- Add points to the polyface.
- Compute each point index as the point is added.
- All data arrays are parallel to the point array.
- Point indices are added in reverse order if indicated by the builder state.
addFacetFromGrowableArrays(points: GrowableXYZArray, normals: GrowableXYZArray, params: GrowableXYArray, colors: number[], edgeVisible?: boolean[]): void
Parameter | Type | Description |
---|---|---|
points | GrowableXYZArray | array of vertices in order around the facet. |
normals | GrowableXYZArray | (optional) array of normals, one per vertex. |
params | GrowableXYArray | (optional) array of uv-parameters, one per vertex. |
colors | number[] | (optional) array of colors, one per vertex. |
edgeVisible | boolean[] | (optional) array of flags, one per vertex, true iff edge starting at corresponding vertex is visible. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1518
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.