create MethodStatic
Construct and return an OffsetMeshOptions
with given parameters.
- Angles are forced to minimum values.
- Clones of the angles are given to the constructor.
create(smoothSingleAngleBetweenNormals: Angle..., smoothAccumulatedAngleBetweenNormals: Angle..., chamferTurnAngleBetweenNormals: Angle...): OffsetMeshOptions
Parameter | Type | Description |
---|---|---|
smoothSingleAngleBetweenNormals | Angle | |
smoothAccumulatedAngleBetweenNormals | Angle | angles that sum to this much may be consolidated for average normal. Default value is 60 degrees. |
chamferTurnAngleBetweenNormals | Angle | when facets meet and the turn angle (i.e., angle between facet normals) is larger than chamferTurnAngleBetweenNormals , a chamfer edge may be added to prevent offset mesh from havingfacets that extend out too far away from the source mesh. Default value is 120 degrees. |
Returns - OffsetMeshOptions
Defined in
- polyface/PolyfaceQuery.ts Line 224
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.