OffsetMeshOptions Class
Options carrier for cloneOffset.
- Default options are strongly recommended.
- The option most likely to be changed is
chamferAngleBetweenNormals
.
Methods
Name | Description | |
---|---|---|
create(smoothSingleAngleBetweenNormals: Angle..., smoothAccumulatedAngleBetweenNormals: Angle..., chamferTurnAngleBetweenNormals: Angle...): OffsetMeshOptions Static | Construct and return an OffsetMeshOptions with given parameters. |
Properties
Name | Type | Description | |
---|---|---|---|
chamferAngleBetweenNormals | Angle | When facets meet and the turn angle (i.e., angle between facet normals) is larger than | |
outputSelector | OffsetMeshSelectiveOutputOptions | undefined | Optional control structure for selective output. | |
smoothAccumulatedAngleBetweenNormals | Angle | Max accumulation of angle between normals to be considered smooth. | |
smoothSingleAngleBetweenNormals | Angle | Max angle between normals to be considered smooth. |
Defined in
- polyface/PolyfaceQuery.ts Line 185
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.