announceFacetsWithSectorCoordinatesAroundEdges Method
For each edge of the graph . .
- Collect coordinates in 4 sectors going around the edge
- Compress with tight tolerance so adjacent sectors with clean point match reduce to a single point.
- Emit as a facet.
announceFacetsWithSectorCoordinatesAroundEdges(polyfaceBuilder: PolyfaceBuilder): void
Parameter | Type | Description |
---|---|---|
polyfaceBuilder | PolyfaceBuilder |
Returns - void
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.