PlaneByOriginAndVectors4d Class
A PlaneByOriginAndVectors4d is a 4d origin and pair of 4d "vectors" defining a 4d plane.
- The parameterization of the plane is
X = origin + vectorU * u + vectorV * v
- With particular weight values
origin.w === 1, vectorU.w === 0, vectorV.w === 0
this is likePlane3dByOriginAndVectors
- With other weights, the deweighted xyz coordinates of points on the 4d plane still form a 3d plane.
Methods
Name | Description | |
---|---|---|
clone(result?: PlaneByOriginAndVectors4d): PlaneByOriginAndVectors4d | Return a clone of this plane | |
fractionToPoint(u: number, v: number, result?: Point4d): Point4d | evaluate plane point (full 3d) at given (u,v) coordinate. | |
isAlmostEqual(other: PlaneByOriginAndVectors4d): boolean | Return true if origin, vectorU, and vectorV pass isAlmostEqual. | |
setFrom(other: PlaneByOriginAndVectors4d): void | copy all content from other plane | |
setOriginAndVectors(origin: Point4d, vectorU: Point4d, vectorV: Point4d): PlaneByOriginAndVectors4d | Copy the contents of origin, vectorU, vectorV parameters to respective member variables | |
setOriginAndVectorsXYZW(x0: number, y0: number, z0: number, w0: number, ux: number, uy: number, uz: number, uw: number, vx: number, vy: number, vz: number, vw: number): PlaneByOriginAndVectors4d | Set all numeric data from complete list of (x,y,z,w) in origin, vectorU, and vectorV | |
createOriginAndTargets3d(origin: Point3d, targetU: Point3d, targetV: Point3d, result?: PlaneByOriginAndVectors4d): PlaneByOriginAndVectors4d Static | create from origin point, (u=1,v=0) point, and (u=0,v=1) point. | |
createOriginAndVectors(origin: Point4d, vectorU: Point4d, vectorV: Point4d, result?: PlaneByOriginAndVectors4d): PlaneByOriginAndVectors4d Static | Create a plane with (copies of) origin, vectorU, vectorV parameters, all given as full 4d points. | |
createOriginAndVectorsXYZW(x0: number, y0: number, z0: number, w0: number, ux: number, uy: number, uz: number, uw: number, vx: number, vy: number, vz: number, vw: number, result?: PlaneByOriginAndVectors4d): PlaneByOriginAndVectors4d Static | Create from complete list of (x,y,z,w) in origin, vectorU, and vectorV | |
createXYPlane(result?: PlaneByOriginAndVectors4d): PlaneByOriginAndVectors4d Static | create a new plane which maps to the cartesian xy plane. |
Properties
Name | Type | Description | |
---|---|---|---|
origin | Point4d | homogeneous origin | |
vectorU | Point4d | homogeneous u-direction vector | |
vectorV | Point4d | homogeneous v-direction vector |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.