UVSurfaceLocationDetail Class
CurveLocationDetail carries point and paramter data about a point evaluated on a curve.
- These are returned by a variety of queries.
- Particular contents can vary among the queries.
Methods
Name | Description | |
---|---|---|
constructor(surface?: UVSurface, uv?: Point2d, point?: Point3d): UVSurfaceLocationDetail | Construct with empty data. | |
createSurfaceUVNumbersPoint(surface: UVSurface, u: number, v: number, point: Point3d): UVSurfaceLocationDetail Static | Create a new detail structure. | |
createSurfaceUVPoint(surface: UVSurface, uv: Point2d, point: Point3d): UVSurfaceLocationDetail Static | Create a new detail structure. |
Properties
Name | Type | Description | |
---|---|---|---|
a | number | A context-specific numeric value. | |
point | Point3d | The point on the surface | |
surface | UVSurface | undefined | The surface being evaluated | |
uv | Point2d | uv coordinates in the surface |
Defined in
- bspline/SurfaceLocationDetail.ts Line 19
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.