LoopCurveLoopCurve Class
Structure carrying a pair of loops with curve geometry.
Methods
Name | Description | |
---|---|---|
constructor(loopA: Loop, curveA: CurvePrimitive, loopB: Loop, curveB: CurvePrimitive): LoopCurveLoopCurve | Constructor | |
setA(loop: Loop, curve: CurvePrimitive): void | Set the loopA and curveA members | |
setB(loop: Loop, curve: CurvePrimitive): void | Set the loopB and curveB members |
Properties
Name | Type | Description | |
---|---|---|---|
curveA | CurvePrimitive | undefined | A curve (typically an edge of loopA) | |
curveB | CurvePrimitive | undefined | A curve (typically an edge of loopB) | |
loopA | Loop | undefined | First loop | |
loopB | Loop | undefined | second loop |
Defined in
- curve/Loop.ts Line 105
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.