moveSignedDistanceFromFraction Method
- Implementation of
CurvePrimitive.moveSignedDistanceFromFraction
. (see comments there!) - Find the segment that contains the start fraction
- Move point-by-point from that position to the start or end (respectively for negative or positive signedDistance)
- Optionally extrapolate
moveSignedDistanceFromFraction(startFraction: number, signedDistance: number, allowExtension: "false", result?: CurveLocationDetail): CurveLocationDetail
Parameter | Type | Description |
---|---|---|
startFraction | number | |
signedDistance | number | |
allowExtension | "false" | |
result | CurveLocationDetail |
Returns - CurveLocationDetail
Defined in
- curve/LineString3d.ts Line 807
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.