createFrom4OutOf5 MethodStatic
Create a transition spiral.
- Inputs must provide exactly 4 of the 5 values
[radius0,radius1,bearing0,bearing1,length
.
createFrom4OutOf5(spiralType: string, radius0: number, radius1: number, bearing0: Angle, bearing1: Angle, arcLength: number, fractionInterval: Segment1d, localToWorld: Transform): undefined | IntegratedSpiral3d
Parameter | Type | Description |
---|---|---|
spiralType | string | one of "clothoid", "bloss", "biquadratic", "cosine", "sine". If undefined, "clothoid" is used. |
radius0 | number | radius (or 0 for tangent to line) at start |
radius1 | number | radius (or 0 for tangent to line) at end |
bearing0 | Angle | bearing, measured CCW from x axis at start. |
bearing1 | Angle | bearing, measured CCW from x axis at end. |
arcLength | number | |
fractionInterval | Segment1d | optional fractional interval for an "active" portion of the curve. if omitted, the full [0,1] is used. |
localToWorld | Transform | placement transform |
Returns - undefined | IntegratedSpiral3d
Defined in
- curve/spiral/IntegratedSpiral3d.ts Line 209
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.