createPolishCubic MethodStatic
Create a polish cubic This is y= m*x^3 with
- m is 1/ (6RL)
- 1/(6RL) is the leading term of the sine series.
- L is nominal length
- R is nominal end radius.
- x ranges up to the x axis distance for which the polish distance series produces f(x)=L
- The support class PolishCubicEvaluator has static methods for the distance series and its inversion.
createPolishCubic(localToWorld: Transform, nominalL1: number, nominalR1: number, activeInterval?: Segment1d): undefined | DirectSpiral3d
Parameter | Type | Description |
---|---|---|
localToWorld | Transform | |
nominalL1 | number | |
nominalR1 | number | |
activeInterval | Segment1d |
Returns - undefined | DirectSpiral3d
Defined in
- curve/spiral/DirectSpiral3d.ts Line 284
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.