createMXCubicAlongArc MethodStatic
Create an MX Cubic whose nominal length is close to along the curve. This is y= m*x^3 with
- m is 1/ (6RL1)
- 1/(6RL) is the leading term of the sine series.
- L1 is an along-the-x-axis distance that is slightly LESS THAN the nominal length
- x is axis position that is slightly LESS than nominal distance along
- L1, x use the approximation `x = s * ( 1 - s^4/ (40 R R L L))
createMXCubicAlongArc(localToWorld: Transform, nominalL1: number, nominalR1: number, activeInterval?: Segment1d): undefined | DirectSpiral3d
Parameter | Type | Description |
---|---|---|
localToWorld | Transform | |
nominalL1 | number | |
nominalR1 | number | |
activeInterval | Segment1d |
Returns - undefined | DirectSpiral3d
Defined in
- curve/spiral/DirectSpiral3d.ts Line 258
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.