createItalian MethodStatic

Create an italian spiral This is y= m*x^3 with

  • x any point on the x axis
  • fraction along the spiral goes to x = fraction * L
  • m is gamma / (6RL)
    • 1/(6RL) is the leading term of the sine series.
    • gamma = 2R/sqrt (4RR-LL) pushes y up a little bit to simulate the lost series terms.
  • L in gamma and m is the

createItalian(localToWorld: Transform, nominalL1: number, nominalR1: number, activeInterval?: Segment1d): undefined | DirectSpiral3d

Parameter Type Description
localToWorld Transform  
nominalL1 number nominal length along the spiral
nominalR1 number  
activeInterval Segment1d  

Returns - undefined | DirectSpiral3d

Defined in

Last Updated: 13 November, 2024