createFromLengthAndRadius MethodStatic
Create (if possible) a DirectSpiral3d, applying various strict conditions appropriate to the spiral type. The parameter list includes extraneous values in order to directly match IntegratedSpiral3d.create, which has greater flexibility about mixtures of values.
- IMPORTANT RESTRICTIONS
- Direct spirals must have the inflection at the origin of their coordinate system, aligned with the x axis.
- hence bearing0 = 0
- hence radius0 = 0
- bearing1 is ignored
- radius1 must be given.
- arcLength must be given,
- Direct spirals must have the inflection at the origin of their coordinate system, aligned with the x axis.
createFromLengthAndRadius(spiralType: string, radius0: number, radius1: number, bearing0: Angle, _bearing1: Angle, arcLength: number, activeInterval: Segment1d, localToWorld: Transform): undefined | TransitionSpiral3d
Parameter | Type | Description |
---|---|---|
spiralType | string | one of the types in DirectSpiralTypeNames |
radius0 | number | radius (or 0 for tangent to line) at start. Must be ZERO or UNDEFINED |
radius1 | number | radius (or 0 for tangent to line) at end. |
bearing0 | Angle | bearing, measured CCW from x axis at start. Must be ZERO or UNDEFINED |
_bearing1 | Angle | |
arcLength | number | |
activeInterval | Segment1d | |
localToWorld | Transform | placement transform |
Returns - undefined | TransitionSpiral3d
Defined in
- curve/spiral/DirectSpiral3d.ts Line 407
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.