createAustralianRail MethodStatic
Create an AustralianRailCorp spiral This is y= m*x^3 with
- x any point on the x axis
fraction
along the spiral goes tox = fraction * L
- m is gamma / (6RL)
- 1/(6RL) is the leading term of the sine series.
gamma = 2R/sqrt (4RR-LL)
pushes y up a little bit to simulate the lost series terms.
createAustralianRail(localToWorld: Transform, nominalL1: number, nominalR1: number, activeInterval?: Segment1d): undefined | DirectSpiral3d
Parameter | Type | Description |
---|---|---|
localToWorld | Transform | |
nominalL1 | number | |
nominalR1 | number | |
activeInterval | Segment1d |
Returns - undefined | DirectSpiral3d
Defined in
- curve/spiral/DirectSpiral3d.ts Line 313
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.