createArema MethodStatic

Create an Arema spiral clothoid approximation

  • X is 2 terms of the clothoid series as a function of nominal distance along
  • Y is 2 terms f the clothoid series as a function of nominal distance along
  • Remark: This is identical to the ChineseCubic

createArema(localToWorld: Transform, nominalL1: number, nominalR1: number, activeInterval?: Segment1d): undefined | DirectSpiral3d

Parameter Type Description
localToWorld Transform axes with inflection at origin, tangent along x axis
nominalL1 number nominal length as used in series LR terms.
nominalR1 number nominal final radius as used in series LR terms
activeInterval Segment1d fractional interval with (0, nominalL1) range for nominal distance along

Returns - undefined | DirectSpiral3d

Defined in

Last Updated: 13 November, 2024