buildRotationalNormalsInLineStrings MethodStatic
Recurse through geometry.children to find linestrings. In each linestring, compute the surface normal annotation from
- the curve tangent stored in the linestring
- the axis of rotation
- a default V vector to be used when the linestring point is close to the axis.
buildRotationalNormalsInLineStrings(geometry: AnyCurve, axis: Ray3d, defaultVectorFromAxis: Vector3d): void
Parameter | Type | Description |
---|---|---|
geometry | AnyCurve | |
axis | Ray3d | |
defaultVectorFromAxis | Vector3d |
Returns - void
Defined in
- curve/Query/CylindricalRange.ts Line 96
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.