fractionToFrenetFrame Method
Construct a frenet frame:
- origin at the point on the curve
- x axis is unit vector along the curve (tangent)
- y axis is perpendicular and in the plane of the osculating circle. y axis is called "main normal"
- z axis perpendicular to those. z axis is called "bi-normal"
fractionToFrenetFrame(fraction: number, result?: Transform): undefined | Transform
Parameter | Type | Description |
---|---|---|
fraction | number | |
result | Transform |
Returns - undefined | Transform
Defined in
- curve/CurvePrimitive.ts Line 182
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.