collectCurvePrimitives Method
Return an array containing only the curve primitives.
- This DEFAULT implementation captures the optional collector and calls collectCurvePrimitivesGo.
collectCurvePrimitives(collectorArray?: CurvePrimitive[], smallestPossiblePrimitives: booleanfalse, explodeLinestrings: booleanfalse): CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | optional array to receive primitives. If present, new primitives are ADDED (without clearing the array.) |
smallestPossiblePrimitives | boolean | if false, CurvePrimitiveWithDistanceIndex returns only itself. If true, it recurses to its (otherwise hidden) children. |
explodeLinestrings | boolean |
Returns - CurvePrimitive[]
Defined in
- curve/CurvePrimitive.ts Line 779
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.