collectCurvePrimitivesGo Method
Return an array containing only the curve primitives.
- This DEFAULT implementation simply pushes
this
to the collectorArray.
collectCurvePrimitivesGo(collectorArray: CurvePrimitive[], _smallestPossiblePrimitives: boolean, _explodeLinestrings: booleanfalse): void
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | array to receive primitives (pushed -- the array is not cleared) |
_smallestPossiblePrimitives | boolean | |
_explodeLinestrings | boolean |
Returns - void
Defined in
- curve/CurvePrimitive.ts Line 766
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.