CurveOps Class
Static methods for miscellaneous curve operations.
Methods
Name | Description | |
---|---|---|
constructor(): CurveOps | ||
appendXYOffsets(curves: AnyCurve | AnyCurve[], offset: number, result: AnyCurve[]): number Static | Construct a separate xy-offset for each input curve. | |
collectChains(fragments: AnyCurve[], gapTolerance: numberGeometry.smallMetricDistance, planeTolerance?: number): undefined | AnyChain Static | Restructure curve fragments as Paths and Loops. | |
collectChainsAsLineString3d(fragments: AnyCurve[], announceChain: (chainPoints: LineString3d) => void, strokeOptions?: StrokeOptions, gapTolerance: numberGeometry.smallMetricDistance, _planeTolerance?: number): void Static | Restructure curve fragments, to be stroked and passed into the callback. | |
collectInsideAndOutsideXYOffsets(fragments: AnyCurve[], offsetDistance: number, gapTolerance: number): { chains?: AnyChain, insideOffsets: AnyCurve[], outsideOffsets: AnyCurve[] } Static | Restructure curve fragments as Paths and Loops, and construct xy-offsets of the chains. | |
constructCurveXYOffset(curves: Path | Loop, offsetDistanceOrOptions: number | OffsetOptions): undefined | CurveCollection Static | Construct curves that are offset from a Path or Loop as viewed in xy-plane (ignoring z). | |
createSingleOffsetPrimitiveXY(curve: CurvePrimitive, offsetDistanceOrOptions: number | OffsetOptions): undefined | CurvePrimitive | CurvePrimitive[] Static | Create the offset of a single curve primitive as viewed in the xy-plane (ignoring z). | |
extendRange(range: Range3d, curves: AnyCurve | AnyCurve[]): Range3d Static | Recursively extend the range by each curve's range, allowing CurvePrimitive, CurveCollection, or array of such at any level. | |
sumLengths(curves: AnyCurve | AnyCurve[]): number Static | Recursively sum curve lengths, allowing CurvePrimitive, CurveCollection, or array of such at any level. |
Defined in
- curve/CurveOps.ts Line 27
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.