tryTransformInPlace Method
Transform the detail in place.
- All numerical properties are transformed directly, except:
- when
curve
is defined,point
andpoint1
are reset by evaluating the transformed curve atfraction
andfraction1
- these properties are untouched:
a
,fraction
,fraction1
,pointQ
- when
tryTransformInPlace(transform: Transform): boolean
@returns true if and only if the transformation was successful. If false, the instance is in an indeterminate state and should not be used.
Parameter | Type | Description |
---|---|---|
transform | Transform | the transform to apply |
Returns - boolean
true if and only if the transformation was successful. If false, the instance is in an indeterminate state and should not be used.
Defined in
- curve/CurveLocationDetail.ts Line 408
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.