createLineSpiralSpiralLine MethodStatic
Compute 2 spirals (all in XY) for a symmetric line-to-line transition.
- First spiral begins at given start point.
- first tangent aims at shoulder
- outbound spiral joins line from shoulder to target.
createLineSpiralSpiralLine(spiralType: IntegratedSpiralTypeName, startPoint: Point3d, shoulderPoint: Point3d, targetPoint: Point3d): undefined | GeometryQuery[]
@returns array with the computed spirals, or undefined if failure.
Parameter | Type | Description |
---|---|---|
spiralType | IntegratedSpiralTypeName | name of spiral type. THIS MUST BE AN "Integrated" SPIRAL TYPE |
startPoint | Point3d | inbound start point. |
shoulderPoint | Point3d | |
targetPoint | Point3d |
Returns - undefined | GeometryQuery[]
array with the computed spirals, or undefined if failure.
Defined in
- curve/CurveFactory.ts Line 474
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.