assembleArcChainOnEllipsoid MethodStatic
Return a Path
containing arcs are on the surface of an ellipsoid and pass through a sequence of points.
- Each arc passes through the two given endpoints and in the plane containing the true surface normal at given
fractionForIntermediateNormal
assembleArcChainOnEllipsoid(ellipsoid: Ellipsoid, pathPoints: GeodesicPathPoint[], fractionForIntermediateNormal: number0.5): Path
Parameter | Type | Description |
---|---|---|
ellipsoid | Ellipsoid | |
pathPoints | GeodesicPathPoint[] | |
fractionForIntermediateNormal | number | fractional position for surface normal used to create the section plane. |
Returns - Path
Defined in
- curve/CurveFactory.ts Line 279
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.