GeodesicPathPoint Class
Detailed data for a point on a 2-angle parameter space.
Methods
Name | Description | |
---|---|---|
constructor(): GeodesicPathPoint | ||
evaluateDerivativesAtCurrentAngles(ellipsoid: Ellipsoid): void | Fill all evaluations at given theta and phi. | |
toAngles(): LongitudeLatitudeNumber | Extract the two angles form this structure to a LongitudeLatitudeNumber structure. | |
evaluateNewtonFunction(pointA: GeodesicPathPoint, pointB: GeodesicPathPoint, pointC: GeodesicPathPoint, values: Float64Array): void Static | Evaluate the newton function and derivatives: |
Properties
Name | Type | Description | |
---|---|---|---|
d1Cross | Vector3d | ||
d2Phi | Vector3d | ||
d2Theta | Vector3d | ||
d2ThetaPhi | Vector3d | ||
dPhi | Vector3d | ||
dTheta | Vector3d | ||
phiRadians | number | Second angle, in radians | |
point | Point3d | ||
thetaRadians | number | First angle, in radians |
Defined in
- geometry3d/Ellipsoid.ts Line 953
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.