intersectionXYPairs MethodStatic
Return xy intersections of 2 curves.
- Curves can be extended if extend flags are set. B-splines are not extended even if the flag is set.
intersectionXYPairs(curveA: AnyCurve, extendA: boolean, curveB: AnyCurve, extendB: boolean, tolerance: numberGeometry.smallMetricDistance): CurveLocationDetailPair[]
Parameter | Type | Description |
---|---|---|
curveA | AnyCurve | first curve |
extendA | boolean | true to allow curveA to extend |
curveB | AnyCurve | second curve |
extendB | boolean | true to allow curveB to extend |
tolerance | number | optional distance tolerance for coincidence |
Returns - CurveLocationDetailPair[]
Defined in
- curve/CurveCurve.ts Line 32
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.