closestPoint Method

Return the closest point on the contained curves.

closestPoint(spacePoint: Point3d, _extend: VariantCurveExtendParameterfalse, result?: CurveLocationDetail): undefined | CurveLocationDetail

@returns details of the closest point.

Parameter Type Description
spacePoint Point3d point in space.
_extend VariantCurveExtendParameter unused here (pass false), but applicable to overrides in Path and BagOfCurves.
result CurveLocationDetail optional pre-allocated detail to populate and return.

Returns - undefined | CurveLocationDetail

details of the closest point.

Defined in

Last Updated: 14 November, 2024