fractionToPointAndDerivative Method
Return the point (x,y,z) and derivative on the curve at fractional position.
- Note that the derivative is "derivative of xyz with respect to fraction".
- The derivative shows the speed of the "fractional point" moving along the curve.
- The derivative is not generally a unit vector. Use
fractionToPointAndUnitTangent
for a unit vector.
fractionToPointAndDerivative(fraction: number, result?: Ray3d): Ray3d
@returns a ray whose origin is the curve point and direction is the derivative with respect to the fraction.
Parameter | Type | Description |
---|---|---|
fraction | number | fractional position along the geometry. |
result | Ray3d | optional receiver for the result. |
Returns - Ray3d
a ray whose origin is the curve point and direction is the derivative with respect to the fraction.
Defined in
- curve/CurveChainWithDistanceIndex.ts Line 572
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.