computeChainDetail Method
Compute the global chain detail corresponding to a local child detail.
computeChainDetail(childDetail: CurveLocationDetail, result?: CurveLocationDetail): undefined | CurveLocationDetail
@returns global (chain) detail with its childDetail
field pointing to the input and its a
field copied from the input, but if a PathFragment for childDetail
cannot be resolved, return undefined.
Parameter | Type | Description |
---|---|---|
childDetail | CurveLocationDetail | the local (fragment) detail, captured as-is. |
result | CurveLocationDetail | optional pre-allocated detail to populate and return. |
Returns - undefined | CurveLocationDetail
global (chain) detail with its childDetail
field pointing to the input and its a
field copied from the input, but if a PathFragment for childDetail
cannot be resolved, return undefined.
Defined in
- curve/CurveChainWithDistanceIndex.ts Line 829
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.