ConstructCurveBetweenCurves Class
Context for constructing a curve that is interpolated between two other curves.
- The only callable method is the static
InterpolateBetween
. - Other methods are called only by
dispatchToGeometryHandler
Extends
Methods
Name | Description | |
---|---|---|
handleArc3d(arc0: Arc3d): any | * To be directly called only by double dispatcher | |
handleLineSegment3d(segment0: LineSegment3d): any | * To be directly called only by double dispatcher | |
handleLineString3d(ls0: LineString3d): any | * To be directly called only by double dispatcher | |
interpolateBetween(geometry0: GeometryQuery, fraction: number, geometry1: GeometryQuery): undefined | GeometryQuery Static | Construct a geometry item which is fractionally interpolated between two others. |
Inherited methods
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.