projectedParameterRange Method
Project instance geometry (via dispatch) onto the given ray, and return the extreme fractional parameters of projection.
projectedParameterRange(ray: Vector3d | Ray3d, lowHigh?: Range1d): undefined | Range1d
@returns range of fractional projection parameters onto the ray, where 0.0 is start of the ray and 1.0 is the end of the ray.
Parameter | Type | Description |
---|---|---|
ray | Vector3d | Ray3d | ray onto which the instance is projected. A Vector3d is treated as a Ray3d with zero origin. |
lowHigh | Range1d | optional receiver for output |
Returns - undefined | Range1d
range of fractional projection parameters onto the ray, where 0.0 is start of the ray and 1.0 is the end of the ray.
Defined in
- curve/Arc3d.ts Line 1345
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.