createScaledXYColumns MethodStatic
Create an arc from center, x column to be scaled, and y column to be scaled.
createScaledXYColumns(center: Point3d, matrix: Matrix3d, radius0: number, radius90: number, sweep?: AngleSweep, result?: Arc3d): Arc3d
Parameter | Type | Description |
---|---|---|
center | Point3d | center of ellipse |
matrix | Matrix3d | matrix whose x and y columns are unit vectors to be scaled by radius0 and radius90 |
radius0 | number | radius in x direction. |
radius90 | number | radius in y direction. |
sweep | AngleSweep | sweep limits |
result | Arc3d | optional preallocated result. |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 345
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.