closestPoint Method
Return details of the closest point on the arc, optionally extending to full ellipse.
closestPoint(spacePoint: Point3d, extend: VariantCurveExtendParameter, result?: CurveLocationDetail): CurveLocationDetail
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | search for point closest to this point. |
extend | VariantCurveExtendParameter | if true, consider projections to the complete ellipse. If false, consider only endpoints and projections within the arc sweep. |
result | CurveLocationDetail | optional preallocated result. |
Returns - CurveLocationDetail
Defined in
- curve/Arc3d.ts Line 821
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.