announceClipIntervals Method
Find intervals of this CurvePrimitive that are interior to a clipper
announceClipIntervals(clipper: Clipper, announce?: AnnounceNumberNumberCurvePrimitive): boolean
@returns true if any "in" segments are announced.
Parameter | Type | Description |
---|---|---|
clipper | Clipper | clip structure (e.g.clip planes) |
announce | AnnounceNumberNumberCurvePrimitive |
Returns - boolean
true if any "in" segments are announced.
Defined in
- curve/Arc3d.ts Line 1220
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.