Clipper Interface
An object containing clipping planes that can be used to clip geometry.
Implemented by
Methods
Name | Description | |
---|---|---|
announceClippedArcIntervals(arc: Arc3d, announce?: AnnounceNumberNumberCurvePrimitive): boolean | Find the portion (or portions) of the arc (if any) that are within the convex clip volume. | |
announceClippedSegmentIntervals(f0: number, f1: number, pointA: Point3d, pointB: Point3d, announce?: AnnounceNumberNumber): boolean | Find the parts of the line segment (if any) that is within the convex clip volume. | |
isPointOnOrInside(point: Point3d, tolerance?: number): boolean | Test if point is on or inside the Clipper's volume. |
Properties
Name | Type | Description | |
---|---|---|---|
appendPolygonClip | AppendPolygonClipFunction | undefined | Optional polygon clip method. |
Defined in
- clipping/ClipUtils.ts Line 84
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.