hasIntersectionWithRay Method
Test if there is any intersection with a ray defined by origin and direction.
- Optionally record the range (null or otherwise) in caller-allocated result.
- If the ray is unbounded inside the clip, result can contain positive or negative "Geometry.largeCoordinateResult" values.
- If no result is provide, there are no object allocations.
hasIntersectionWithRay(ray: Ray3d, maximalRange?: Range1d): boolean
Parameter | Type | Description |
---|---|---|
ray | Ray3d | |
maximalRange | Range1d | optional Range1d to receive parameters along the ray. |
Returns - boolean
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.