computePlanePlanePlaneIntersectionsInAllConvexSets Method
Collect the output from computePlanePlanePlaneIntersections in all the contained convex sets.
computePlanePlanePlaneIntersectionsInAllConvexSets(points: Point3d[], rangeToExtend: Range3d, transform?: Transform, testContainment: booleantrue): number
@returns number of points.
Parameter | Type | Description |
---|---|---|
points | Point3d[] | (optional) array to which computed points are to be added. |
rangeToExtend | Range3d | |
transform | Transform | (optional) transform to apply to the points. |
testContainment | boolean | if true, test each point to see if it is within the convex set (send false if confident that the convex set is rectilinear set such as a slab. Send true if chiseled corners are possible). |
Returns - number
number of points.
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.