centroidAreaNormal MethodStatic
Return a Ray3d with (assuming the polygon is planar and not self-intersecting):
origin
at the centroid of the (3D) polygondirection
is the unit vector perpendicular to the planea
is the area.
centroidAreaNormal(points: IndexedXYZCollection | Point3d[]): undefined | Ray3d
Parameter | Type | Description |
---|---|---|
points | IndexedXYZCollection | Point3d[] |
Returns - undefined | Ray3d
Defined in
- geometry3d/PolygonOps.ts Line 527
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.