PointStreamRangeCollector Class
PointStream handler to collect the range of points.
Extends
-
Methods
Name | Description | |
---|---|---|
constructor(): PointStreamRangeCollector | ||
claimResult(): Range3d | ||
handleXYZ(x: number, y: number, z: number): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
endChain(_chainData: MultiLineStringDataVariant, _isLeaf: boolean): void Inherited | ||
startChain(_chainData: MultiLineStringDataVariant, _isLeaf: boolean): void Inherited |
Defined in
- geometry3d/PointStreaming.ts Line 95
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.