Point2dArray Class
The Point2dArray
class contains static methods that act on arrays of 2d points.
Methods
Name | Description | |
---|---|---|
constructor(): Point2dArray | ||
clonePoint2dArray(data: Point2d[]): Point2d[] Static | Return an array containing clones of the Point3d data[] | |
isAlmostEqual(dataA: Point2d[], dataB: Point2d[]): boolean Static | Return true if arrays have same length and matching coordinates. | |
pointCountExcludingTrailingWraparound(data: Readonly<WritableXAndY>[]): number Static | Return the number of points when trailing points that match point 0 are excluded. |
Defined in
- geometry3d/PointHelpers.ts Line 316
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.