createFromTransformColumnsXYAndLengths MethodStatic
Return a Plane3dByOriginAndVectors, with
- origin is the translation (aka origin) from the Transform
- vectorU is the X column of the transform
- vectorV is the Y column of the transform.
createFromTransformColumnsXYAndLengths(transform: Transform, xLength: number, yLength: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors
Parameter | Type | Description |
---|---|---|
transform | Transform | source transform |
xLength | number | optional length to impose on vectorU. |
yLength | number | optional length to impose on vectorV. |
result | Plane3dByOriginAndVectors | optional preexisting result |
Returns - Plane3dByOriginAndVectors
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.