inverse Method
Return the inverse matrix. The return is undefined if the matrix is singular (e.g. has parallel columns or a zero magnitude column)
- If
result == this
, then content of inverse ofthis
matrix is copied intothis
. Otherwise, inverse ofthis
is stored inresult
. - Note: Each Matrix3d object caches its own inverse (
this.inverseCoffs
) and has methods to multiply the inverse times matrices and vectors (e.g.,multiplyMatrixInverseMatrix
,multiplyMatrixMatrixInverse
,multiplyInverse
). Hence explicitly constructing this new inverse object is rarely necessary.
inverse(result?: Matrix3d): undefined | Matrix3d
Parameter | Type | Description |
---|---|---|
result | Matrix3d |
Returns - undefined | Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 2237
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.