fastSymmetricEigenvalues Method
Factor this
matrix as a product U * lambda * UT
where U
is an orthogonal matrix and lambda
is a diagonal matrix.
- Note: You must apply this function to a
symmetric
matrix. Otherwise, the lower triangle is ignored and the upper triangle is mirrored to the lower triangle to enforce symmetry. - Math details can be found at docs/learning/geometry/Matrix.md
fastSymmetricEigenvalues(leftEigenvectors: Matrix3d, lambda: Vector3d): boolean
Parameter | Type | Description |
---|---|---|
leftEigenvectors | Matrix3d | a matrix that its columns will be filled by the left eigenvectors of this Matrix3d(allocated by caller, computed and filled by this function). Note that columns of leftEigenVectors will be mutually perpendicular because this matrix is symmetric. |
lambda | Vector3d | a vector that its entries will be filled by eigenvalues of this Matrix3d (allocated bycaller, computed and filled by this function). |
Returns - boolean
Defined in
- geometry3d/Matrix3d.ts Line 1147
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.