factorPerpendicularColumns Method
Factor this
matrix as a product VD * U
where VD
has mutually perpendicular columns and U
is orthogonal.
factorPerpendicularColumns(matrixVD: Matrix3d, matrixU: Matrix3d): boolean
Parameter | Type | Description |
---|---|---|
matrixVD | Matrix3d | a matrix that its columns will be filled by rotating columns of this to make them mutuallyperpendicular (allocated by caller, computed and filled by this function). |
matrixU | Matrix3d | a matrix that its columns will be filled by the right eigenvectors of thisTranspose * this (allocated by caller, computed and filled by this function). Note that columns of matrixU will be mutually perpendicular because thisTranspose * this matrix is symmetric. |
Returns - boolean
Defined in
- geometry3d/Matrix3d.ts Line 1268
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.