factorOrthogonalScaleOrthogonal Method
Factor this
matrix as a product V * D * U
where V
and U
are orthogonal and D
is diagonal with
positive entries.
- This is formally known as the
Singular Value Decomposition
orSVD
.
factorOrthogonalScaleOrthogonal(matrixV: Matrix3d, scale: Point3d, matrixU: Matrix3d): boolean
Parameter | Type | Description |
---|---|---|
matrixV | Matrix3d | an orthogonal matrix that its columns will be filled by the left eigenvectors ofthisTranspose * this (allocated by caller, computed and filled by this function). |
scale | Point3d | singular values of this (allocated by caller, computed and filled by this function).The singular values in the scale are non-negative and decreasing. |
matrixU | Matrix3d | an orthogonal matrix that its columns will be filled by the right eigenvectors ofthisTranspose * this (allocated by caller, computed and filled by this function). |
Returns - boolean
Defined in
- geometry3d/Matrix3d.ts Line 1294
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.