createRotationAroundVector MethodStatic
Return the matrix for rotation of angle
around desired axis
- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/CubeTransform
createRotationAroundVector(axis: Vector3d, angle: Angle, result?: Matrix3d): undefined | Matrix3d
@returns the rotation matrix
or undefined
(if axis magnitude is near zero).
Parameter | Type | Description |
---|---|---|
axis | Vector3d | the axis of rotation |
angle | Angle | the angle of rotation |
result | Matrix3d | caller-allocated matrix (optional) |
Returns - undefined | Matrix3d
the rotation matrix
or undefined
(if axis magnitude is near zero).
Defined in
- geometry3d/Matrix3d.ts Line 750
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.