createPartialRotationVectorToVector MethodStatic
Return a matrix that rotates a fraction of the angular sweep from vectorA to vectorB.
createPartialRotationVectorToVector(vectorA: Vector3d, fraction: number, vectorB: Vector3d, result?: Matrix3d): undefined | Matrix3d
Parameter | Type | Description |
---|---|---|
vectorA | Vector3d | initial vector position |
fraction | number | fractional rotation (1 means rotate all the way) |
vectorB | Vector3d | final vector position |
result | Matrix3d | optional result matrix. |
Returns - undefined | Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 1332
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.