createCapture MethodStatic
Create a Matrix3d with caller-supplied coefficients and optional inverse coefficients.
- The inputs are captured into (i.e., owned by) the new Matrix3d.
- The caller is responsible for validity of the inverse coefficients.
- If either array is insufficiently sized, it is ignored.
createCapture(coffs: Float64Array, inverseCoffs?: Float64Array): Matrix3d
@returns a Matrix3d populated by a coffs array.
Parameter | Type | Description |
---|---|---|
coffs | Float64Array | (required) array of 9 coefficients. |
inverseCoffs | Float64Array | (optional) array of 9 coefficients. |
Returns - Matrix3d
a Matrix3d populated by a coffs array.
Defined in
- geometry3d/Matrix3d.ts Line 450
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.